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knowledgebase : FAQs > Viewing

Please view the attached document for infomation on the browser configurations required in order to successfully access ProjectDox. For ProjectDox versions below 8.3.8.8, see System Use Requirements 8-3. For ProjectDox version 8.3.8.8 and above, see System Use Requirements 8-3-8-8 and Above.  

The following browsers are covered within this document: 

  • Internet Explorer 11
  • Firefox 
  • Chrome 
  • Safari

 

 

 



Description

By default, document-style PDFs will scroll and CAD-style PDFs will zoom.

Solution

Locate the "myrdrv.ini"  on the Job Processor

It is located in the "Data Drive:\Program Files (x86)\IGC\Brava! Enterprise .NET\JobProcessor" directory

there is a parameter under the "PDF2DL" section called:

ViewState=

0 will set the settings to the default
1 will set it to always be document-style
2 will set it to always be CAD-style

 

This needs to be done on both Job Processors if you want to change the behavior from the default to a different setting.

 

Revised 02-18-2015

Problem:

 

After saving a PDF from Microsoft Internet Explorer that was opened from the PDF Converter Professional Web Viewer, the PDF file does not appear in the specified save location.

 

 

 

Cause:

 

This issue may occur if the "Enable Protected Mode" option is enabled within Microsoft Internet Explorer. With this Internet Explorer option enabled, all files saved from Internet Explorer are actually saved to a "Virtualized" folder instead of the specified folder. For example, if a PDF file is intended to be saved to the Windows Desktop, the PDF is actually saved to the following virtualized folder instead:

 

C:\Users\%username%\AppData\Local\Microsoft\Windows\Temporary Internet Files\Virtualized\C\Users\%username%\Desktop

 

 

Solution:

 

Please disable the "Enable Protected Mode" option within Microsoft Internet Explorer by following the steps below:

 

Open Microsoft Internet Explorer.

Go to the "Tools" menu.

Click "Internet Options".

Go to the "Security" tab.

Disable/uncheck the option to "Enable Protected Mode".

Click "Apply", then "OK".

Restart Microsoft Internet Explorer.

Now PDF documents that are saved from the PDF Web Viewer will be saved to the specified location.

ProjectDox Monitor Size and Settings Recommendations.

Description

The User Account Control (UAC), depending on the User's Permission level and rights, may prevent the user from being able to perform some functions with the Brava Client:


• When installing the Brava Client, UAC (if on) can prevent the Brava Client from being installed as UAC blocks the user's ability to write files being downloaded by the browser (Internet Explorer).


• With the Brava Client installed, UAC (if on) can prevent the Brava Client from saving/writing files to the local file system.


• During Brava's client side loading/processing, UAC (if on) can prevent Brava's client side loading/processing by preventing the Brava Client from writing the temporary output CDL files to the user's temp directory.

Solution


To turn off UAC:

1. From the Control Panel, open User Accounts.

2. Click the “Turn User Account Control on or off” link.

3. In the “Turn on User Account Control (UAC) to make your computer more secure” options screen, un-check “Use User Account Control (UAC) to help protect your computer” check box.

4. Click “OK” and restart the system.


Note: The User's permissions level/rights will affect how the UAC works.

 

Revised 02-18-2015

 

 

 

 

ProjectDox Viewer Technologies

ProjectDox Viewer is available in ActiveX for PDOX 6.x, 7.x, 8.x.  ProjectDox Flash Viewer is available for PDOX 8.1.x.   ProjectDox HTML5 Viewer is available for PDOX 8.2.x and PDOX 8.3.x. The ActiveX client offers the highest level of functionality and performance and works best on Windows with IE.

Features

ActiveX

Flash

HTML

View

x

1

1

Supports Video

 

x

 

Find

x

x

x

Annotate

x

x

x

Publishing

x

x

x

Redaction

x

 

4

Compare

x

 

3

Measure

x

   

Takeoff

x

   

Print

x

2

2

1: Limited CAD viewing support
2: Printing supported, but performance and features less than ActiveX/Java versions
3: Text compare report only
4: Redaction not supported on iPad

Platform

ActiveX

Flash

HTML

PC

x

x

x

MAC

 

x

x

Browsers

1

x

x

Tablet

   

iPad

Note 1: ActiveX client will work on most browsers, but performs best in IE.

 

Revised 02-18-2015

When encountering sporadic batch stamping issues it could be due to the URL length being too long. To remedy this, please follow the steps below:

 

1)     Click the Virtual Directory folder.

2)     Open up the Configuration Editor.

3)     Select system.web/httpRuntime from the dropdown.

4)     Update the maxUrlLength to 500 characters.

5)     Once changes are made, select the Apply action button. 


See Attached image for further guidance

Description 

The performance observed while scrolling with the scrollbar in the file viewer is dependent upon the client machine specifications.

This is because the file viewer will try to refresh the window as quickly as the computer can handle, but if there is not sufficient CPU cycles or if the video card isn't up to the task, readability during scrolling may not be as nice as it could be on a nicer, more powerful machine.

For example, a workstation which has an i5 processor and at least 3GB of RAM and an average video card won't likely witness any blurriness or ghosting effect when scrolling through a text document.

However, if you were to open a very complex document (for example, one that has a great deal of content or lots of vectors in drawing files and graphics on it), when you scroll it is likely to have a bit of a "ghosting" effect that makes text harder to read.

This also depends on the monitors themselves. For example, some monitors may have only a 10ms refresh rate whereas nicer monitors will have a 5ms or less refresh rate.

All in all, the issue of "ghosting" or blurry text while scrolling with the scroll bar is dependent on the hardware available to the file viewer.

Solution

A workaround (if you do not have sufficient hardware) is to simply tap the down arrow while viewing a document. This will scroll down approximately an inch and will avoid this blurriness or "ghosting" effect.

 

Revised 02-18-2015

Description

If a user cannot open the Markup layer and they are receiving an error message with a HTTP Response Code of 404, the reason could be that the HTTP GET request size oversteps its default setting of 2048 bytes. This happens because file viewer encodes filenames and usernames in the query string so if your filenames or usernames are quite long, it is highly likely that you will reach the limit for some users or for specific files.

 

Solution

To resolve the issue, increase the request limit in IIS Configuration from the default 2048 to a higher number, for example, try changing the value to 4096.

Steps


This can be done either via command line:

appcmd set
config /section:requestfiltering /requestlimits.maxquerystring:4096

Or via IIS Manager:

  1. Go to DefaultBravaWebSite
  2. Request Filtering
  3. Headers (tab)
  4. Edit Feature Setting
  5. Set "Maximum Query String (Bytes)" = 4096 (or higher) 

 

Revised 02-18-2015

Issue/Description: When logged into ProjectDox, the pages do not load successfully, or they are unable to navigate within the website.

Troubleshooting Steps (Include necessary screenshots):

  1. Try to login using a different web browser
    1. Open ProjectDox site using a different browser
    2. Log in using credentials
    3. Try to navigate through the application

If the pages load successfully in a different browser and you can navigate the website, the issue is with the browser.

    2. Try clearing browser cache – Corrupted/bad cache can cause issues with pages loading and page functionality. You will need to clear browsing history, cookies, and files.

    1. Click on the links below for instructions on how to delete history from each of the browsers (Chrome, Firefox, Edge, Internet Explorer, and Safari)

    3. After clearing the history, try to open ProjectDox and navigate through the application. If the issue persists, you may need to verify the browser configuration settings – verify the pop-up blocker is turned off and the ProjectDox URL is in the trusted sites. If the settings are correct, the next step would be to reinstall the browser and test if that resolves the issue.